Changelog


バージョン

From: To:

凡例: A - API, F - Frontend, G - Agent, J - Java gateway, P - Proxy, S - Server, T - Template

修正IDVer.修正内容
ZBXNEXT-94927.0.22Tadded VeloCloud SD-WAN Edge by HTTP template
ZBXNEXT-103647.0.22Jadded commentary to web service config file that indicates that this config can be extended via Include
ZBXNEXT-103067.0.22APSupdated maximum supported MySQL version to 9.5
ZBXNEXT-102897.0.22ASupdated maximum supported TimescaleDB version to 2.23
ZBXNEXT-102317.0.22Tadded support for the new syntax to MySQL templates
ZBXNEXT-101697.0.22Tadded Ribbon SBC Edge by HTTP template
ZBXNEXT-101687.0.22Tadded Ribbon SBC SWe core by HTTP and Ribbon SBC SWe CE by HTTP templates
ZBXNEXT-100127.0.22Gadded both SHOW SLAVE STATUS and SHOW REPLICA STATUS for Zabbix agent 2 MySQL plugin
ZBX-276407.0.22Aprevented possibility of SQL injection when "groupBy" and "sortfield" parameters are passed to *.get API methods and contain same SQL injection value
ZBX-271997.0.22Ffixed graph view failing to display dependent item from web scenario
ZBX-271887.0.22PSfixed validation of TLS configuration before adding autoregistered host
ZBX-271557.0.22Tfixed OID for protected host memory item in Stormshield SNS by SNMP template
ZBX-271547.0.22Ffixed rare occasion of infinite loop in graph scale generation
ZBX-270537.0.22Fadded space between tags on Web monitoring list page and in LDAP settings
ZBX-270337.0.22Ffixed incorrect disabling of Execute now option in Latest data item popup for users of type User
ZBX-270327.0.22Sfixed header executing error from JavaScript request
ZBX-270317.0.22Ffixed Host navigator widget not loading when Show problems is set to None
ZBX-270207.0.22Ffixed user with limited permissions access to map containing submap with inaccessible host or hostgroup
ZBX-269517.0.22Afixed dashboard template get to filter by provided templateids when using accessible hosts to find dashboard templates without hosts
ZBX-269497.0.22Tchanged macro names in the NetApp AFF A700 by HTTP template
ZBX-269467.0.22PSfixed memory being reserved by pollers due to memory-intensive script items or in async pollers due to large transfers
ZBX-269007.0.22PSfixed Zabbix server warning log for out-of-order value identifier detection to clarify data source
ZBX-268677.0.22PSfixed dependent item error message upon master item change
ZBX-268307.0.22Afixed undefined array key "host_status" on triggers import
ZBX-267697.0.22PSimproved performance by removing "or" conditions from "in" statements
ZBX-267397.0.22Tfixed item logic in Nextcloud by HTTP template
ZBX-267027.0.22PSfixed query failures on Oracle in lld_hosts_remove
ZBX-266657.0.22Ffixed widget configuration form layout on narrow screens
ZBX-266407.0.22Gfixed Zabbix agent built with statically linked curl library crashing on web.page.get[] items
ZBX-266267.0.22Tadded additional GRANT statements for both MSSQL templates
ZBX-266237.0.22Tfixed ODBC poller error handling in Zabbix server/proxy health templates
ZBX-265627.0.22Afixed 'Allowed memory size exhausted' issue while importing a cloned template
ZBX-265007.0.22Gfixed system.users.num metric incorrect returned value for both agents
ZBX-264627.0.22Aupdated and minimized the ability to achieve full table lock when deleting different API objects
ZBX-264517.0.22FSfixed inventory macros not being resolved in script and browser type items
ZBX-264277.0.22Afixed resetting of discovery rule filter on import
ZBX-263037.0.22AFfixed escaping of special characters in regular expressions
ZBX-262897.0.22Ffixed preprocessed result not displaying white spaces correctly
ZBX-262527.0.22Afixed runtime error when linking template with matching discovery rule to host
ZBX-262187.0.22Gfixed incorrect function name in log for Zabbix agent 2
ZBX-261117.0.22Gfixed JSON output for vfs.dev.discovery DEVTYPE field
ZBX-260187.0.22PSadded fping command execution time limit
ZBX-252847.0.22Aprevented web scenarios being inherited to host prototypes; fixed inability to delete parent host in such case
ZBX-250377.0.22AFfixed slow performance of show queries for dbversion and charset on MySQL
ZBX-241407.0.22Gfixed not being able to build Zabbix agent with statically linked curl library and inability to use curl without ssl for "web.page.get[...]" items