Changelog
凡例: A - API, F - Frontend, G - Agent, J - Java gateway, P - Proxy, S - Server, T - Template
| 修正ID | Ver. | 修正内容 | |||||||
|---|---|---|---|---|---|---|---|---|---|
| ZBXNEXT-9492 | 7.0.22 | T | added VeloCloud SD-WAN Edge by HTTP template | ||||||
| ZBXNEXT-10364 | 7.0.22 | J | added commentary to web service config file that indicates that this config can be extended via Include | ||||||
| ZBXNEXT-10306 | 7.0.22 | A | P | S | updated maximum supported MySQL version to 9.5 | ||||
| ZBXNEXT-10289 | 7.0.22 | A | S | updated maximum supported TimescaleDB version to 2.23 | |||||
| ZBXNEXT-10231 | 7.0.22 | T | added support for the new syntax to MySQL templates | ||||||
| ZBXNEXT-10169 | 7.0.22 | T | added Ribbon SBC Edge by HTTP template | ||||||
| ZBXNEXT-10168 | 7.0.22 | T | added Ribbon SBC SWe core by HTTP and Ribbon SBC SWe CE by HTTP templates | ||||||
| ZBXNEXT-10012 | 7.0.22 | G | added both SHOW SLAVE STATUS and SHOW REPLICA STATUS for Zabbix agent 2 MySQL plugin | ||||||
| ZBX-27640 | 7.0.22 | A | prevented possibility of SQL injection when "groupBy" and "sortfield" parameters are passed to *.get API methods and contain same SQL injection value | ||||||
| ZBX-27199 | 7.0.22 | F | fixed graph view failing to display dependent item from web scenario | ||||||
| ZBX-27188 | 7.0.22 | P | S | fixed validation of TLS configuration before adding autoregistered host | |||||
| ZBX-27155 | 7.0.22 | T | fixed OID for protected host memory item in Stormshield SNS by SNMP template | ||||||
| ZBX-27154 | 7.0.22 | F | fixed rare occasion of infinite loop in graph scale generation | ||||||
| ZBX-27053 | 7.0.22 | F | added space between tags on Web monitoring list page and in LDAP settings | ||||||
| ZBX-27033 | 7.0.22 | F | fixed incorrect disabling of Execute now option in Latest data item popup for users of type User | ||||||
| ZBX-27032 | 7.0.22 | S | fixed header executing error from JavaScript request | ||||||
| ZBX-27031 | 7.0.22 | F | fixed Host navigator widget not loading when Show problems is set to None | ||||||
| ZBX-27020 | 7.0.22 | F | fixed user with limited permissions access to map containing submap with inaccessible host or hostgroup | ||||||
| ZBX-26951 | 7.0.22 | A | fixed dashboard template get to filter by provided templateids when using accessible hosts to find dashboard templates without hosts | ||||||
| ZBX-26949 | 7.0.22 | T | changed macro names in the NetApp AFF A700 by HTTP template | ||||||
| ZBX-26946 | 7.0.22 | P | S | fixed memory being reserved by pollers due to memory-intensive script items or in async pollers due to large transfers | |||||
| ZBX-26900 | 7.0.22 | P | S | fixed Zabbix server warning log for out-of-order value identifier detection to clarify data source | |||||
| ZBX-26867 | 7.0.22 | P | S | fixed dependent item error message upon master item change | |||||
| ZBX-26830 | 7.0.22 | A | fixed undefined array key "host_status" on triggers import | ||||||
| ZBX-26769 | 7.0.22 | P | S | improved performance by removing "or" conditions from "in" statements | |||||
| ZBX-26739 | 7.0.22 | T | fixed item logic in Nextcloud by HTTP template | ||||||
| ZBX-26702 | 7.0.22 | P | S | fixed query failures on Oracle in lld_hosts_remove | |||||
| ZBX-26665 | 7.0.22 | F | fixed widget configuration form layout on narrow screens | ||||||
| ZBX-26640 | 7.0.22 | G | fixed Zabbix agent built with statically linked curl library crashing on web.page.get[] items | ||||||
| ZBX-26626 | 7.0.22 | T | added additional GRANT statements for both MSSQL templates | ||||||
| ZBX-26623 | 7.0.22 | T | fixed ODBC poller error handling in Zabbix server/proxy health templates | ||||||
| ZBX-26562 | 7.0.22 | A | fixed 'Allowed memory size exhausted' issue while importing a cloned template | ||||||
| ZBX-26500 | 7.0.22 | G | fixed system.users.num metric incorrect returned value for both agents | ||||||
| ZBX-26462 | 7.0.22 | A | updated and minimized the ability to achieve full table lock when deleting different API objects | ||||||
| ZBX-26451 | 7.0.22 | F | S | fixed inventory macros not being resolved in script and browser type items | |||||
| ZBX-26427 | 7.0.22 | A | fixed resetting of discovery rule filter on import | ||||||
| ZBX-26303 | 7.0.22 | A | F | fixed escaping of special characters in regular expressions | |||||
| ZBX-26289 | 7.0.22 | F | fixed preprocessed result not displaying white spaces correctly | ||||||
| ZBX-26252 | 7.0.22 | A | fixed runtime error when linking template with matching discovery rule to host | ||||||
| ZBX-26218 | 7.0.22 | G | fixed incorrect function name in log for Zabbix agent 2 | ||||||
| ZBX-26111 | 7.0.22 | G | fixed JSON output for vfs.dev.discovery DEVTYPE field | ||||||
| ZBX-26018 | 7.0.22 | P | S | added fping command execution time limit | |||||
| ZBX-25284 | 7.0.22 | A | prevented web scenarios being inherited to host prototypes; fixed inability to delete parent host in such case | ||||||
| ZBX-25037 | 7.0.22 | A | F | fixed slow performance of show queries for dbversion and charset on MySQL | |||||
| ZBX-24140 | 7.0.22 | G | fixed not being able to build Zabbix agent with statically linked curl library and inability to use curl without ssl for "web.page.get[...]" items |